Outage - Message Delivery and Reporting Affected

Incident Report for EZ Texting Status

Resolved

We have finished our investigation and monitoring; our team found that the outage was partial, not full, and the majority of messages sent during the service issue period were confirmed delivered.

If you see any inconsistencies with your delivery reporting during the outage period of 9:30am to 1:30pm PT, please let our customer support team know at answers@eztexting.com. Thank you for your patience.
Posted Nov 09, 2025 - 14:51 PST

Investigating

We are currently experiencing issues delivering messages and generating reports. We recommend pausing your campaigns until we're fully online.

We're very sorry for the inconvenience; thank you for your patience while we work towards a fix.
Posted Nov 09, 2025 - 12:52 PST
This incident affected: EZ Texting (EZ Texting Services, EZ Texting SMS, EZ Texting MMS).