We are currently experiencing a platform degradation impacting MMS traffic

Incident Report for EZ Texting Status

Resolved

The earlier MMS sending delays caused by our messaging aggregators have been resolved. Message delivery has returned to normal, and all systems are operating as expected.

Thank you for your patience and understanding while we worked to restore full service.
Posted Nov 04, 2025 - 12:55 PST

Investigating

One of our messaging partners has reported an ongoing MMS service interruption, which may cause delays in message delivery for some users. We recommend avoiding message retries at this time, as additional attempts may also be delayed.
Posted Nov 04, 2025 - 09:59 PST
This incident affected: External Connectivity (MMS - Short Codes, MMS - Long Codes, MMS - Toll-Free), CallFire (CallFire MMS), and EZ Texting (EZ Texting MMS).