Degraded Message Delivery on AT&T with Trackable Links

Incident Report for EZ Texting Status

Resolved

Our records show a minor impact on message delivery to AT&T devices for messages that between 4/29-5/7. The incident has now been resolved.
Posted May 08, 2026 - 13:52 PDT

Investigating

Messages that contain Trackable Links are seeing degraded message delivery to AT&T devices. We recommend avoiding the use of trackable links until this is resolved in order to prioritize your message delivery.
Posted May 08, 2026 - 11:15 PDT
This incident affected: EZ Texting (EZ Texting SMS).