[Resolved] Service Interruption and Performance Issues

Incident Report for EZ Texting Status

Resolved

We experienced a short period of degraded performance starting around 1:30 PM EST / 10:30 AM PST today. The issue has since been resolved and services are now operating normally.
If you're still noticing any issues or observed anything unusual during that time, please feel free to reach out to our support team with any specific examples so we can take a closer look.
Thanks for your patience and understanding!
Posted Apr 14, 2025 - 10:30 PDT