Provisioning Delays

Incident Report for EZ Texting Status

Resolved

The provisioning delays have been resolved. Our team worked with our aggregator partners to restore normal provisioning timelines. All provisioning is now processing as expected. Thank you for your patience.
Posted Jan 23, 2026 - 07:51 PST

Investigating

We are currently experiencing provisioning delays. Our team is actively working with our aggregator partners to identify and resolve the issue as quickly as possible. We will provide updates as more information becomes available.
Posted Jan 22, 2026 - 06:24 PST
This incident affected: External Connectivity (Number Provisioning).