T-Mobile MMS Delivery Failures

Incident Report for EZ Texting Status

Resolved

The delivery issue affecting MMS messages sent to T-Mobile recipients from 10DLC numbers has been resolved as of ~2:30pm EST (11:30am PST). Monitoring confirms that errors have stopped, with the last error observed at 11:11am PST.
Posted Sep 02, 2025 - 14:21 PDT

Investigating

We are aware of an issue causing intermittent delivery failures for MMS messages to T-Mobile recipients when sent from 10DLC numbers (10 digit local numbers). Our teams are investigating and will provide updates as more information becomes available.
Posted Sep 02, 2025 - 10:49 PDT
This incident affected: External Connectivity (MMS - Long Codes).