AT&T carrier network — intermittent delivery failures

Incident Report for EZ Texting Status

Resolved

As of 1:30 AM EST, the AT&T delivery issue has been resolved. Messages are delivering normally.
Posted May 01, 2026 - 06:16 PDT

Identified

AT&T is experiencing intermittent message delivery issues across several US regions. SMS and MMS messages destined to AT&T subscribers are seeing elevated failure rates and latency above baseline. Our systems are actively monitoring.
Posted Apr 30, 2026 - 15:21 PDT
This incident affected: CallFire (CallFire SMS, CallFire MMS) and EZ Texting (EZ Texting SMS, EZ Texting MMS).