Multi-Factor Authentication (MFA) Functionality

Incident Report for EZ Texting Status

Resolved

The issue affecting the new Multi-Factor Authentication process has been fully resolved. Users should now be able to log in without any interruptions.

Thank you for your patience while our team worked to identify the cause and implement the fix.
Posted Dec 11, 2025 - 07:40 PST

Investigating

We are currently investigating an issue affecting the new Multi-Factor Authentication process. Our team is working to identify the cause and implement a fix. We will provide an update as soon as a resolution has been deployed.

Thank you for your patience.
Posted Dec 11, 2025 - 07:13 PST
This incident affected: EZ Texting (EZ Texting Website).