Provisioning Impacted for newly-Order Numbers
Incident Report for EZ Texting Status
Resolved
The provisioning outage has been resolved. Thank you for your patience.
Posted Jul 24, 2024 - 06:56 PDT
Identified
An outage with a core industry entity is causing delays with the provisioning of local numbers for texting. We recommend that you refrain from switching service to a new number at this time, if you have an existing number that is already live. We will share more information as soon as we've received an update from our industry partners.
Posted Jul 23, 2024 - 15:32 PDT
This incident affected: CallFire (CallFire Services) and External Connectivity (Number Provisioning).